AGEphone Business1.8.017 - Google Play
You'll be able to see results in few seconds.
Publisher Description
AGEphone Business brings full VoIP functionality to your Android device.
AGEphone Business is fast and delivers high quality calls not only over WiFi but also mobile networks, depending on signal strength.
AGEphone Business is designed to be used for the business scene. It supports call transfer, park hold and multi-lines by default.
This is a provider free softphone and designed to work with any provider you wish to use. It is not bound to any specific VoIP service so just add your provider data to the simple settings menu and all the advantages of modern IP telephony are but a tap away. No matter where you are, AGEphone Business keeps you connected to your network of contacts.
Features:
- Manage multiple SIP account
- speed dial
- Call History
- Dial Prefix
- Predictive Dial
- Multi-lines
- Call transfer
- Address Book Integration
- Park hold
- UDP/TCP/TLS supported
- Keep Alive
- High quality sound, low delay buffering
- Calling rules (Incoming / Outgoing)
- Change ringtone per number
- Voice Activity Detection(VAD)
- Speaker-phone
- STUN Support
- Jitter buffer for WiFi and Mobile
- DTMF: Inband, RFC 2833, SIP_INFO
- Multiple Codecs(G.711u / G.711a / GSM / Speex / SILK / G722 /ilbc)
- Hold: RFC 2543, RFC 3264
About AGEphone Business
The company that develops AGEphone Business is ageet Corporation. The latest version released by its developer is 1.8.017.
To install AGEphone Business on your Android device, just click the green Continue To App button above to start the installation process. The app is listed on our website since 2019-12-03 and was downloaded 0 times. We have already checked if the download link is safe, however for your own protection we recommend that you scan the downloaded app with your antivirus. Your antivirus may detect the AGEphone Business as malware as malware if the download link to com.ageet.AGEphone.Business is broken.
How to install AGEphone Business on your Android device:
- Click on the Continue To App button on our website. This will redirect you to Google Play.
- Once the AGEphone Business is shown in the Google Play listing of your Android device, you can start its download and installation. Tap on the Install button located below the search bar and to the right of the app icon.
- A pop-up window with the permissions required by AGEphone Business will be shown. Click on Accept to continue the process.
- AGEphone Business will be downloaded onto your device, displaying a progress. Once the download completes, the installation will start and you'll get a notification after the installation is finished.
Program Details
System requirements
Download information
Pricing
Version History
version 1.8.017
posted on 2019-12-03
- Fix several issues
version 1.8.016
posted on 2019-09-17
version
posted on 2016-12-19
- Fixed call history updating,- Fixed AGEphone CRM login
version 1.0.053
posted on 2012-10-29
Several fixes and updates
Disclaimer
Official Google Play Link
We do not host AGEphone Business on our servers. We did not scan it for viruses, adware, spyware or other type of malware. This app is hosted by Google and passed their terms and conditions to be listed there. We recommend caution when installing it.
The Google Play link for AGEphone Business is provided to you by apps112.com without any warranties, representations or guarantees of any kind, so access it at your own risk.
If you have questions regarding this particular app contact the publisher directly. For questions about the functionalities of apps112.com contact us.

